Mudamos o layout e isso pode gerar alguns bugs nas postagens, se perceber algum avise: contanto@informaticando–ajuda.com

Como fazer uma extensão velha pegar num modelo Firefox que seria incompatível com a mesma

Por: João Manoel,

Você acaba de atualizar seu Firefox e percebe que a sua extensão favorita não é compatível com ele. Mas não troque de navegador por isso! Eis a solução:

A saída para driblar esse problema está no próprio Firefox. Use a barra de endereços do mouse para digitar o comando about:config. E a brincadeira vai começar. (foto abaixo)

Escreva isto

Depois, como padrão do Firefox, ele te diz para não mexer, com "medo" de você fazer alguma bobagem, mas o que vamos fazer aqui não vai alterar nada. Então clique em "Serei cuidadoso, prometo!".

Serei cuidadoso

Depois você vai cair num página com todas as configurações do Firefox, mas iginore-a. Clique em qualquer área do local com o botão direito do mouse e vá em Nova opção > Boolean.

Nova opção - Boolean

Aparecerá uma janelinha com um campo chamado “Forneça o nome da opção:” É hora de digitar “extensions.checkCompatibility” (sem aspas) e teclar Enter. A seguir, é preciso definir esse parâmetro como falso.

Digite isso

False

Isso evitará que o Firefox cheque a compatibilidade das extensões antes de instalá-las.

Dependendo do Addon, ele continuará sendo barrado, mas a solução é repetir o processo e criar outra expressão booleana, com o parâmetro “extensions.checkUpdateSecurity”, que também deve ter valor “falso”.

Agora é só reiniciar o Firefox e abrir a porta para as (extensões) velhinhas!

PS. Se você usa versões de teste do Firefox, tente o addon Nightly Tester Tools, que garante a compatibilidade das extensões velhas com o 3.7 e outros alphas e betas que estão por vir.

Nosso artigo termina aqui. Comentem!